您的位置 首页 配资交流

MACD金叉的选股公式大全

1、5日线上穿10日线

2、MACD金叉

3、KDJ金叉(KDJ数值由9、3、3调整为8、2、2)

4、成交量指标背离

通达信预警选股公式

A1:=CROSS(MA(C,5),MA(C,10));

A2:=CROSS(MACD.DIF,MACD.DEA);

A3:=CROSS(KDJ.K(8,2,2),KDJ.D(8,2,2));

A4:=CROSS(MA(V,5),MA(V,10));

XG:A1AND A2 AND A3 AND 4;

三金叉选股完整源码,绝无未来函数

均线、成交量、MACD同时金叉

MA1:=MA(CLOSE,5);

MA2:=MA(CLOSE,10);

AA:=CROSS(MA1,MA2);

AAA:=COUNT(AA,3)>=1;

T1:=MA(VOL,5);

T2:=MA(VOL,10);

BB:=CROSS(T1,T2);

BBB:=COUNT(BB,3)>=1;

DIF:=EMA(CLOSE,12)- EMA(CLOSE,26);

DEA:=EMA(DIF,9);

MACD:=(DIF-DEA)*2;

CC:=CROSS(DIF,DEA);

CCC:=COUNT(CC,3)>=1;

三金:=AAAAND BBB AND CCC;

三金叉:FILTER(三金,3),COLORFF00FF;

使用证明:该选股公式适合超级大盘,快进快出带有肯定的成本原因,此时的股价仍然进入拉高拔升阶段。

要求使用者特别关注股价所处的位置,如果过度高位防止庄家诱多。低位可大胆搏杀,短期回档被套也有回旋余地。

8、四线粘合

选股公式 macd金叉_macd金叉选股_macd金叉选股

N1:=5;N2:=10;N3:=20;M:=1;

MA1:=MA(C,N1);MA2:=MA(C,N2);MA3:=MA(C,N3);

A3:=V>REF(V,1)*1.5AND V>MA(V,5);

MAX(MA1,MAX(MA2,MA3))/MIN(MA1,MIN(MA2,MA3))

ANDC>O AND V> REF(V,1) AND FINANCE(7)MA(V,5);

XG:AAND A1 AND A2 AND A3 ;

10、多线粘合

V0:=EMA(C,5);

V1:=EMA(C,10);

V2:=EMA(C,15);

V3:=EMA(C,30);

V4:=EMA(C,60);

M1:=1000*V1/V4=975;

M2:=1000*V2/V4=980;

M3:=1000*V3/V4=985;

M4:=M1AND M2 AND M3 AND CROSS(V0,V1);

M5:=M1AND M2 AND M3 AND CROSS(V0,V3);

M4 ORM5;

11、MACD天天挣钱选股指标公式

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

XG:CROSS(REF(DEA,1),REF(DIFF,1))AND CROSS(DIFF,DEA);

12、短线之王

VAR1:=(-100)*(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3));

CROSS(VAR1,-87)AND OPEN=1.099*REF(CLOSE,1) AND INDEXC>0.98*REF(INDEXC,1) ANDCLOSEDEA,DIF,DRAWNULL),COLORRED,LINETHICK2;

IF(DEA>REF(DEA,1),DEA,DRAWNULL),COLORMAGENTA,LINETHICK2;

DRAWICON(CROSS(DIF,DEA),DEA,25);

DRAWICON(CROSS(DEA,DIF),DEA,24);

14、MACD底位反转点

DIF:EMA(CLOSE,12)-EMA(CLOSE,135);

选股公式 macd金叉_macd金叉选股_macd金叉选股

DEA:=EMA(DIF,9);

MACD:=(DIF-DEA)*2;

反转:MACDREF(MACD ,1) AND REF(MACD ,1)

ANDREF(MACD ,2)

ANDREF(MACD ,3)

15.冠军MACD资金流向

DIFF:=EMA(CLOSE,3)-EMA(CLOSE,7);

DEA:=EMA(DIFF,3);

MACD2:=2*(DIFF-DEA);

(CLOSE

(CLOSE

(CLOSE

(CLOSE

DU0:=CROSS(DIFF,0);

UD0:=CROSS(0,DIFF);

TDU0:=BARSLAST(DU0);

TUD0:=BARSLAST(UD0);

DU3:=REF(DU0,1);

UD3:=REF(UD0,1);

TDU3:=BARSLAST(DU3);

TUD3:=BARSLAST(UD3);

UDGLINE:=IF(TDU3

JDU0:=REF(CLOSE,1)UDGLINE AND TDU0

JUD0:=REF(CLOSE,1)>=REF(UDGLINE,1)AND CLOSE

JDU1:=JDU0AND COUNT(JDU0,TDU0)=1;

JUD1:=JUD0AND COUNT(JUD0,TUD0)=1;

JDU2:=JDU1AND REF(BARSLAST(JUD1),1)

JUD2:=JUD1AND REF(BARSLAST(JUD1),1)>REF(BARSLAST(JDU1),1);

JDU3:=JDU1AND REF(BARSLAST(JUD1),1)>REF(BARSLAST(JDU1),1);

JUD3:=JUD1AND REF(BARSLAST(JUD1),1)

BSLINE:=IF(BARSLAST(JDU2)

(0,MACD2),1)))),IF(REF(CROSS(MACD2,0),1),HHV(HIGH,2),REF(HHV(HIGH,2),BARSLAST(REF(CROSS(MACD2,0),1)))));

STICKLINE(MACD2>=0,0,MACD2,2,1),COLOR0000FF;

STICKLINE(MACD2>=0AND MACD2

STICKLINE(MACD2

STICKLINE(MACD2REF(MACD2,1),0,MACD2,2,1),COLORFFFF00;

DIFIFF,LINETHICK2,COLOR0000FF;

MACDEA,COLORFF0000;

DEF:MACD2,LINETHICK0,COLORFFFF00;

STICKLINE(CLOSE>0,0,0,2,0),COLOR808080;

DEFUT:=BARSLAST(CROSS(MACD2,0));

DEFDT:=BARSLAST(CROSS(0,MACD2));

DEFUL:=IF(MACD2>=0,HHV(MACD2,DEFUT+1),REF(HHV(MACD2,DEFUT+1),DEFDT+1));

DEFDL:=IF(MACD2

DEFU2L:=REF(DEFUL,DEFUT+1);

DEFD2L:=REF(DEFDL,DEFDT+1);

DRAWICON(LLV(MACD2,4)>0AND MACD2REF(MACD2,2) ANDREF(MACD2,2)>REF(MACD2,3),MACD2,2);

DRAWICON(HHV(MACD2,4)REF(MACD2,1) AND REF(MACD2,1)

DRAWICON((JUD1OR BARSLAST(JDU1)>BARSLAST(JUD1)) AND MACD2>=0 ANDREF(MACD2,1)DEFU2L,MACD2,5);

DRAWICON((JDU1OR BARSLAST(JDU1)REF(DEFD2L,1) ANDMACD2

VAR111:=JDU1OR BARSLAST(JDU1)

VAR112:=HHV(MACD2,4)REF(MACD2,1) AND REF(MACD2,1)

16、变色MACD

DIFIF1:=EMA(CLOSE,12)- EMA(CLOSE,26);

DEAEA1:=EMA(DIFIF1,9);

MACD1:=2*(DIFIF1-DEAEA1),STICK;

MACD2:=EMA(MACD1,3);

STICKLINE(MACD1>MACD2AND MACD1>0,0,MACD1,1,0),COLORRED;

STICKLINE(MACD1>MACD2AND MACD1

STICKLINE(MACD1

macd金叉选股_选股公式 macd金叉_macd金叉选股

STICKLINE(MACD1>=0OR MACD1=DEAEA1,DIFIF1,DRAWNULL),COLORRED,LINETHICK2;

弱:IF(DEAEA1>=DIFIF1,DEAEA1,DRAWNULL),COLORFF9900,LINETHICK2;

DRAWICON(CROSS(DIFIF1,DEAEA1),DIFIF1+0.1,1);

DRAWICON(CROSS(DEAEA1,DIFIF1),-0.5,2);

DRAWTEXT(CROSS(DIFIF1,DEAEA1),DIFIF1,”),LINETHICK2,COLORYELLOW;

17、至尊MACD{注意用到了未来函数DCLOSE}{本指标只做策略参考}

DIFF:EMA(DCLOSE,12)-EMA(DCLOSE,26);

DEA:EMA(DIFF,9),COLORFFFF00;

MACD:(DIFF-DEA)*2;

STICKLINE(MACD>=0AND MACD>=REF(MACD,1),0,MACD,1,0),COLORRED;

STICKLINE(MACD>=0AND MACD=0));

二次金叉:=CROSS(DIFF,DEA)AND DEA

STICKLINE(二次金叉,0,0.2,2,0),COLORFF00FF;

DRAWTEXT(二次金叉,DEA*1.06,’二次金叉’),COLORRED;

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

底背离:=REF(CLOSE,A1+1)>CLOSEAND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);

DRAWTEXT(底背离,-0.2-MACD,’底背离’),COLORWHITE;

A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));

顶背离:=REF(CLOSE,A2+1)DIFFAND CROSS(DEA,DIFF);

DRAWTEXT(顶背离,0.2+MACD,’顶背离’),COLORWHITE;

18、条件选股公式:(双佛手向上)缺省周期:日线

======================================================================

DIFF :=EMA(CLOSE,12) – EMA(CLOSE,26);

DEA :=EMA(DIFF,27);

MACD :=2*(DIFF-DEA);

CLOSE>OPENAND MA(CLOSE,5)>MA(CLOSE,10) andMA(CLOSE,10)>MA(CLOSE,30)

andDIFF>DEA AND MACD>REF(MACD,1) and DIFF>0 AND DEA>0 andMA(VOL,5)>MA(VOL,34)

andMA(CLOSE,30)>=REF(MA(CLOSE,30),1)=======================================================================================

根据《南征北战之二》中的双佛手向上思路编写,指标用法:

1.DIFF线回调DEA线附近时不背离,又调头向上。

选股公式 macd金叉_macd金叉选股_macd金叉选股

2.30日均线走平或向下,同时5日线和10日线在30日线上方金叉,且隔日收下跌。

3.5日均量线回调至34日均量线附近时不背离,又调头向上。

以上三个条件能同时建立时将有一波上升浪macd金叉选股,应果断买入。

将MACD指标的m参数调为27

19、条件选股公式:(漫步青云)缺省周期:日线

======================================================================

DIFF :=EMA(CLOSE,12) – EMA(CLOSE,26);

DEA :=EMA(DIFF,27);

dje:=DIFF>=0and DEA>=0 and CROSS(DIFF,DEA);

a5:=MA(CLOSE,5)>MA(CLOSE,10);

v5:=VOL>MA(VOL,5)and MA(VOL,5)>MA(VOL,10);

dje anda5 AND V5 AND MA(CLOSE,30)>=REF(MA(CLOSE,30),1)======================================================================

将macd指标的参数调为12,26,27

主要用法:当30日均线走平或攀升,5日均量大于10日均量,当日成交量大于5日均量,

5日均线金叉或已背离10日均线,macd指标中diff线在0轴上反弹dea线,DIFF线下穿0轴后,又再度上穿并在0轴或0轴上背离dea线,应果断介入。

但若此时K线离30日macd金叉选股,30周,30小时均线较远,不能介入

20、======================================================================

条件选股公式:(空中缆绳)缺省周期:日线

======================================================================

DIFF :=EMA(CLOSE,12) – EMA(CLOSE,26);

DEA :=EMA(DIFF,27);

MACD :=2*(DIFF-DEA);

b:=MIN(DIFF,DEA)/MAX(diff,dea)>0.95;

MA(CLOSE,30)>REF(MA(CLOSE,30),1)and diff>0 and dea>0 AND MACD>REF(MACD,1) and b

======================================================================

将MACD指标的参数调为sh:12;long:26;M:27

用法:30日均线上扬或走平,主力开始洗盘。

这时macd指标中的DIFF线随股价的反弹而与DEA线在0轴上粘合数值基本相同股票配资,只要5日均线在30日均线上方金叉或已背离10日均线股票配资,macd指标红柱加长,DIFF线摆脱DEA线上扬,就是买些。

———————————————————————

以上公式经过验证有效!

关于作者: 股票配资

热门文章

发表评论

邮箱地址不会被公开。 必填项已用*标注